IWIFW(4FREEBSD) - Linux man page online | Special files
Firmware Module for Intel PRO/Wireless 2200BG/2225BG/2915ABG driver.
October 15, 2015
IWIFW(4) BSD Kernel Interfaces Manual IWIFW(4)
BSD October 15, 2015 BSD
NAMEiwifw — Firmware Module for Intel PRO/Wireless 2200BG/2225BG/2915ABG driver
SYNOPSISTo compile this module into the kernel, place the following line in your kernel configura‐ tion file: device iwifw This will include three firmware images inside the kernel. If you want to pick only the firmware image for the mode you want to operate your network adapter in choose one of the following: device iwibssfw device iwiibssfw device iwimonitorfw Alternatively, to load the driver as a module at boot time, place the following lines in loader.conf(5): iwi_bss_load="YES" iwi_ibss_load="YES" iwi_monitor_load="YES"
DESCRIPTIONThis module provides access to firmware sets for the Intel PRO/Wireless 2200BG/2225BG/2915ABG series of IEEE 802.11 adapters. It may be statically linked into the kernel, or loaded as a module. For the loaded firmware to be enabled for use the license at /usr/share/doc/legal/intel_iwi.LICENSE must be agreed to by adding the following line to loader.conf(5): legal.intel_iwi.license_ack=1
FILES/usr/share/doc/legal/intel_iwi.LICENSE iwifw firmware license
SEE ALSOiwi(4), firmware(9)
|This manual||Reference||Other manuals|
|iwifw(4freebsd)||referred by||if_iwi(4freebsd) | iwi(4freebsd)|
|refer to||firmware(9freebsd) | iwi(4freebsd)|