IXGBE(4FREEBSD) - Linux man page online | Special files
Intel(R) 10Gb Ethernet driver for the FreeBSD operating system.
December 19, 2010
IXGBE(4) BSD Kernel Interfaces Manual IXGBE(4)
BSD December 19, 2010 BSD
NAMEixgbe — Intel(R) 10Gb Ethernet driver for the FreeBSD operating system
SYNOPSISTo compile this driver into the kernel, place the following line in your kernel configura‐ tion file: device ixgbe Alternatively, to load the driver as a module at boot time, place the following line in loader.conf(5): if_ixgbe_load="YES"
DESCRIPTIONThe ixgbe driver provides support for PCI 10Gb Ethernet adapters based on the Intel 82598EB Intel(R) Network Connections. The driver supports Jumbo Frames, MSIX, TSO, and RSS. For questions related to hardware requirements, refer to the documentation supplied with your Intel 10GbE adapter. All hardware requirements listed apply to use with FreeBSD. Support for Jumbo Frames is provided via the interface MTU setting. Selecting an MTU larger than 1500 bytes with the ifconfig(8) utility configures the adapter to receive and transmit Jumbo Frames. The maximum MTU size for Jumbo Frames is 16114. This driver version supports VLANs. For information on enabling VLANs, see ifconfig(8).
HARDWAREThe ixgbe driver supports the following cards: · Intel(R) 10 Gigabit XF SR/AF Dual Port Server Adapter · Intel(R) 10 Gigabit XF SR/LR Server Adapter · Intel(R) 82598EB 10 Gigabit AF Network Connection · Intel(R) 82598EB 10 Gigabit AT CX4 Network Connection
DIAGNOSTICSixgbe%d: Unable to allocate bus resource: memory A fatal initialization error has occurred. ixgbe%d: Unable to allocate bus resource: interrupt A fatal initialization error has occurred. ixgbe%d: watchdog timeout -- resetting The device has stopped responding to the network, or there is a problem with the network connection (cable).
SUPPORTFor general information and support, go to the Intel support website at: http://support.intel.com. If an issue is identified with the released source code on the supported kernel with a sup‐ ported adapter, email the specific information related to the issue to ⟨@intel.com⟩.
SEE ALSOaltq(4), arp(4), netintro(4), ng_ether(4), polling(4), vlan(4), ifconfig(8)
HISTORYThe ixgbe device driver first appeared in FreeBSD 7.0.
AUTHORSThe ixgbe driver was written by Intel Corporation <@intel.com>.
|This manual||Reference||Other manuals|
|ixgbe(4freebsd)||referred by||ALTQ(4freebsd) | altq(4freebsd) | if_ix(4freebsd) | if_ixgbe(4freebsd) | if_vlan(4freebsd) | ix(4freebsd) | netmap(4freebsd) | vlan(4freebsd)|
|refer to||arp(4freebsd) | ifconfig(8) | netintro(4freebsd) | ng_ether(4freebsd) | polling(4freebsd) | vlan(4freebsd)|