KBDMUX(4FREEBSD) - Linux man page online | Special files
July 12, 2005
KBDMUX(4) BSD Kernel Interfaces Manual KBDMUX(4)
BSD July 12, 2005 BSD
NAMEkbdmux — keyboard multiplexer
SYNOPSISdevice kbdmux In /boot/device.hints: hint.kbdmux.0.disabled="1"
DESCRIPTIONThe kbdmux keyboard driver provides support for basic keyboard multiplexing. It is built around the idea of a “super keyboard”. The kbdmux driver acts as a master keyboard consum‐ ing input from all slave keyboards attached to it. Slave keyboards can be attached to or detached from the kbdmux keyboard driver with the kbdcontrol(1) utility.
SEE ALSOkbdcontrol(1), atkbd(4), syscons(4), ukbd(4), vt(4)
HISTORYThe kbdmux module was implemented in FreeBSD 6.0.
AUTHORSMaksim Yevmenkin <@yahoo.com>
CAVEATSThe kbdmux keyboard driver switches all slave keyboards into K_RAW mode. Thus all slave keyboards attached to the kbdmux keyboard share the same state. The kbdmux keyboard is log‐ ically equivalent to one keyboard with lots of duplicated keys.
|This manual||Reference||Other manuals|
|refer to||atkbd(4freebsd) | syscons(4freebsd) | ukbd(4freebsd) | vt(4freebsd)|