LGE(4FREEBSD) - Linux man page online | Special files
Level 1 LXT1001 NetCellerator PCI Gigabit Ethernet adapter driver.
July 16, 2005
LGE(4) BSD Kernel Interfaces Manual LGE(4)
BSD July 16, 2005 BSD
NAMElge — Level 1 LXT1001 NetCellerator PCI Gigabit Ethernet adapter driver
SYNOPSISTo compile this driver into the kernel, place the following lines in your kernel configura‐ tion file: device miibus device lge Alternatively, to load the driver as a module at boot time, place the following line in loader.conf(5): if_lge_load="YES"
DESCRIPTIONThe lge driver provides support for various NICs based on the Level 1 LXT1001 NetCellerator Gigabit Ethernet controller chip. The LXT1001 supports fiber PHYs and also a GMII port for use with 10/100/1000 copper PHYs, however there are currently no NICs on the market that use this feature. The LXT1001 supports TCP/IP checksum offload for receive and VLAN-based filtering as well as a 64-bit multicast hash filter. It also supports jumbo frames, which can be configured via the interface MTU setting. Selecting an MTU larger than 1500 bytes with the ifconfig(8) utility configures the adapter to receive and transmit jumbo frames. Using jumbo frames can greatly improve performance for certain tasks, such as file transfers and data streaming. The lge driver supports the following media types: autoselect Enable autoselection of the media type and options. The user can manually over‐ ride the autoselected mode by adding media options to rc.conf(5). 1000baseSX Set 1000baseSX operation over fiber optic cable. Both full-duplex and half-duplex modes are supported. The lge driver supports the following media options: full-duplex Force full duplex operation. half-duplex Force half duplex operation. For more information on configuring this device, see ifconfig(8).
HARDWAREAdapters supported by the lge driver include: · SMC TigerCard 1000 (SMC9462SX) · D-Link DGE-500SX
DIAGNOSTICSlge%d: couldn't map memory A fatal initialization error has occurred. lge%d: couldn't map ports A fatal initialization error has occurred. lge%d: couldn't map interrupt A fatal initialization error has occurred. lge%d: no memory for softc struct! The driver failed to allocate memory for per-device instance information during initialization. lge%d: failed to enable memory mapping! The driver failed to initialize PCI shared memory mapping. This might happen if the card is not in a bus-master slot. lge%d: no memory for jumbo buffers! The driver failed to allocate memory for jumbo frames during initialization. lge%d: watchdog timeout The device has stopped responding to the network, or there is a problem with the network connection (cable).
SEE ALSOarp(4), miibus(4), netintro(4), ng_ether(4), ifconfig(8) Level 1 LXT1001 Programming Manual, http://www.FreeBSD.org/~wpaul/Level1/LXT1001SRM.pdf.
HISTORYThe lge device driver first appeared in FreeBSD 4.4.
AUTHORSThe lge driver was written by Bill Paul <@windriver.com>.
|This manual||Reference||Other manuals|
|lge(4freebsd)||referred by||if_lge(4freebsd) | miibus(4freebsd)|
|refer to||arp(4freebsd) | ifconfig(8) | miibus(4freebsd) | netintro(4freebsd) | ng_ether(4freebsd)|