MAC_TEST(4FREEBSD) - Linux man page online | Special files
MAC framework testing policy.
July 25, 2015
MAC_TEST(4) BSD Kernel Interfaces Manual MAC_TEST(4)
BSD July 25, 2015 BSD
NAMEmac_test — MAC framework testing policy
SYNOPSISTo compile the testing policy into your kernel, place the following lines in your kernel configuration file: options MAC options MAC_TEST Alternately, to load the testing module at boot time, place the following line in your ker‐ nel configuration file: options MAC and in loader.conf(5): mac_test_load="YES"
DESCRIPTIONThe mac_test policy module implements a testing facility for the MAC framework. Among other things, mac_test will try to catch corrupt labels the system is attempting to destroy and drop to the debugger. Additionally, a set of statistics regarding the number of times vari‐ ous MAC framework entry points have been called is stored in the security.mac.test sysctl(8) tree. Label Format No labels are defined for mac_test.
SEE ALSOmac(4), mac_biba(4), mac_bsdextended(4), mac_ifoff(4), mac_lomac(4), mac_mls(4), mac_none(4), mac_partition(4), mac_portacl(4), mac_seeotheruids(4), mac(9)
HISTORYThe mac_test policy module first appeared in FreeBSD 5.0 and was developed by the TrustedBSD Project.
AUTHORSThis software was contributed to the FreeBSD Project by Network Associates Labs, the Secu‐ rity Research Division of Network Associates Inc. under DARPA/SPAWAR contract N66001-01-C-8035 (“CBOSS”), as part of the DARPA CHATS research program.
BUGSWhile the MAC Framework design is intended to support the containment of the root user, not all attack channels are currently protected by entry point checks. As such, MAC Framework policies should not be relied on, in isolation, to protect against a malicious privileged user.
|This manual||Reference||Other manuals|
|mac_test(4freebsd)||referred by||ddb(4freebsd) | mac(4freebsd) | mac(9freebsd) | mac_biba(4freebsd) | mac_bsdextended(4freebsd) | mac_ifoff(4freebsd) | mac_lomac(4freebsd) | mac_mls(4freebsd) | mac_none(4freebsd) | mac_partition(4freebsd) | mac_portacl(4freebsd) | mac_seeotheruids(4freebsd) | mac_stub(4freebsd)|
|refer to||mac(4freebsd) | mac(9freebsd) | mac_biba(4freebsd) | mac_bsdextended(4freebsd) | mac_ifoff(4freebsd) | mac_lomac(4freebsd) | mac_mls(4freebsd) | mac_none(4freebsd) | mac_partition(4freebsd) | mac_portacl(4freebsd) | mac_seeotheruids(4freebsd) | sysctl(8)|