MAN.CONF(5) - Linux man page online | File formats
Configuration file for man.
December 28, 2016
MAN.CONF(5) File Formats Manual MAN.CONF(5)
Debian December 28, 2016 MAN.CONF(5)
NAMEman.conf - configuration file for man
DESCRIPTIONThis is the configuration file for the man(1), apropos(1), and makewhatis(8) utilities. Its presence, and all directives, are optional. This file is an ASCII text file. Leading whitespace on lines, lines starting with ‘#’, and blank lines are ignored. Words are separated by whitespace. The first word on each line is the name of a configuration directive. The following directives are supported: manpath path Override the default search path for man(1), apropos(1), and makewhatis(8). It can be used multiple times to specify multiple paths, with the order determining the manual page search order. Each path is a tree containing subdirectories whose names consist of the strings ‘man’ and/or ‘cat’ followed by the names of sections, usually single digits. The former are supposed to contain unformatted manual pages in mdoc(7) and/or man(7) format; file names should end with the name of the section preceded by a dot. The latter should contain preformatted manual pages; file names should end with ‘.0’. Creating a mandoc.db(5) database with makewhatis(8) in each directory configured with manpath is recommended and necessary for apropos(1) to work, but not strictly required for man(1). output option [value] Configure the default value of an output option. These directives are overridden by the -O command line options of the same names. For details, see the mandoc(1) manual. option value used by -T fragment none html includes string html indent integer ascii, utf8 man string html paper string ps, pdf style string html width integer ascii, utf8 _whatdb path/whatis.db This directive provides the same functionality as manpath, but using a historic and misleading syntax. It is kept for backward compatibility for now, but will eventually be removed.
EXAMPLESThe following configuration file reproduces the defaults: installing it is equivalent to not having a man.conf file at all. manpath /usr/share/man manpath /usr/X11R6/man manpath /usr/local/man
SEE ALSOapropos(1), man(1), makewhatis(8)
HISTORYA relatively complicated man.conf file format first appeared in 4.3BSD-Reno. For OpenBSD 5.8, it was redesigned from scratch, aiming for simplicity.
AUTHORSIngo Schwarze <@openbsd.org>
|This manual||Reference||Other manuals|
|man.conf(5)||referred by||makewhatis(8) | mapropos(1) | mman(1) | pm(1) | powerman(1) | xman(1)|
|refer to||apropos(1) | makewhatis(8) | man(1) | man(7) | mandoc(1) | mandoc.db(5) | mdoc(7)|