MDIO(4FREEBSD) - Linux man page online | Special files
IEEE 802.3 Management Data Input/Output interface.
December 17, 2015
MDIO(4) BSD Kernel Interfaces Manual MDIO(4)
BSD December 17, 2015 BSD
NAMEmdio — IEEE 802.3 Management Data Input/Output interface
SYNOPSISTo compile this driver into the kernel, place the following line in your kernel configura‐ tion file: device mdio
DESCRIPTIONThe mdio driver provides an interconnection between the Media Access Control (MAC) sublayer and Physical Layer (PHY) entities' control and status registers, as defined by the IEEE 802.3 Standard. The mdio layer allows device drivers to share common support code for various external PHY devices. MDIO is one of two signal interfaces that comprise the Media Independent Interface (MII) defined by the IEEE 802.3 Standard. The miibus(4) driver provides support for devices that require full MII support.
STANDARDSMore information on MDIO can be found in the IEEE 802.3 Standard.
HISTORYThe mdio driver first appeared in FreeBSD 10.0.
AUTHORSThe driver was written by Stefan Bethke <@lassitu.de>.
|This manual||Reference||Other manuals|