ME(4FREEBSD) - Linux man page online | Special files
Encapsulating network device.
November 7, 2014
ME(4) BSD Kernel Interfaces Manual ME(4)
BSD November 7, 2014 BSD
NAMEme — encapsulating network device
SYNOPSISTo compile the driver into the kernel, place the following line in the kernel configuration file: device me Alternatively, to load the driver as a module at boot time, place the following line in loader.conf(5): if_me_load="YES"
DESCRIPTIONThe me network interface pseudo device encapsulates datagrams into IP. These encapsulated datagrams are routed to a destination host, where they are decapsulated and further routed to their final destination. me interfaces are dynamically created and destroyed with the ifconfig(8) create and destroy subcommands. This driver corresponds to RFC 2004. Datagrams are encapsulated into IP with a shorter encapsulation. The original IP header is modified and the modifications are inserted between the so modified header and the original payload. The protocol number 55 is used for outer header.
NOTESFor correct operation, the me device needs a route to the decapsulating host that does not run over the tunnel, as this would be a loop.
SEE ALSOgif(4), gre(4), inet(4), ip(4), netintro(4), protocols(5), ifconfig(8), sysctl(8)
AUTHORSAndrey V. Elsukov <@FreeBSD.org>
|This manual||Reference||Other manuals|
|me(4freebsd)||referred by||gre(4freebsd) | if_gre(4freebsd)|
|refer to||gif(4freebsd) | gre(4freebsd) | ifconfig(8) | inet(4freebsd) | ip(4freebsd) | netintro(4freebsd) | protocols(5) | sysctl(8)|