NANDSIM(4FREEBSD) - Linux man page online | Special files
NAND Flash simulator driver.
March 8, 2012
NANDSIM(4) BSD Kernel Interfaces Manual NANDSIM(4)
BSD March 8, 2012 BSD
NAMEnandsim — NAND Flash simulator driver
SYNOPSISdevice nand device nandsim options ALQ
DESCRIPTIONThe nandsim is part of the FreeBSD NAND framework nand(4) and can be characterized with the following highlights: · plugs into the nand(4) framework APIs as if it were a hardware controller (hanging on the nexus bus) with real NAND chips connected to it · physically part of the kernel code (either statically linked into the kernel image or built as a module) · controlled with a user space program nandsim(8) From the user perspective, the nandsim allows for imitating ONFI-compliant NAND Flash devices as if they were attached to the system via a virtual controller. Some nandsim features rely on the ability to log contents to a file, which is achieved through the alq(9) facility.
SEE ALSOnand(4), nandsim.conf(5), nandsim(8)
STANDARDSOpen NAND Flash Interface Working Group (ONFI).
HISTORYThe nandsim support first appeared in FreeBSD 10.0.
AUTHORSThe nandsim kernel driver was developed by Grzegorz Bernacki. This manual page was written by Rafal Jaworowski.
|This manual||Reference||Other manuals|