NG_UI(4FREEBSD) - Linux man page online | Special files
UI netgraph node type.
January 19, 1999
NG_UI(4) BSD Kernel Interfaces Manual NG_UI(4)
BSD January 19, 1999 BSD
NAMEng_UI — UI netgraph node type
DESCRIPTIONThe UI node type has two hooks, upstream and downstream. Packets received on downstream must have 0x03 (indicating unnumbered information) as their first byte; if not the packet is dropped. This byte is then stripped and the remainder of the packet sent out on upstream. Conversely, packets received on upstream will have a 0x03 byte prepended to them before being forwarded out on the downstream hook.
HOOKSThis node type supports the following hooks: downstream Downstream connection. Packets on this side of the node have a 0x03 as their first byte. upstream Upstream connection. Packets on this side of the node have the initial 0x03 byte stripped off.
CONTROL MESSAGESThis node type supports only the generic control messages.
SHUTDOWNThis node shuts down upon receipt of a NGM_SHUTDOWN control message, or when both hooks have been disconnected.
SEE ALSOnetgraph(4), ngctl(8)
HISTORYThe ng_UI node type was implemented in FreeBSD 4.0.
AUTHORSJulian Elischer <@FreeBSD.org>
|This manual||Reference||Other manuals|