NG_ATMLLC(4FREEBSD) - Linux man page online | Special files
ATM LLC netgraph node type.
March 8, 2004
NG_ATMLLC(4) BSD Kernel Interfaces Manual NG_ATMLLC(4)
BSD March 8, 2004 BSD
NAMEng_atmllc — ATM LLC netgraph node type
DESCRIPTIONThe atmllc node type translates frames in to and out of ATM LLC encapsulation, as specified by RFC 1483. In LLC encapsulation the protocol of a given protocol data unit (PDU) is spec‐ ified by an IEEE 802.2 LLC header, possibly followed by an IEEE 802.1a SubNetwork Attachment Point (SNAP) header. This node currently handles the Ethernet and FDDI protocols. The node transmits and receives ATM PDUs on the atm hook. Received PDUs are decoded and forwarded to the ether or fddi hooks as appropriate. Data received on the ether or fddi hooks are assumed to be full Ethernet or FDDI packets as appropriate and are encapsulated into a PDU and transmitted via the atm hook.
HOOKSThis node type supports the following hooks: atm ATM connection. Typically, this hook would be connected to a ng_atm(4) node, which handles transmission of ATM PDUs over an ATM device. ether Ethernet connection. This hook sends and receives Ethernet frames. This would nor‐ mally be connected to an ng_eiface(4) node if in use. fddi FDDI connection. This hook sends and receives FDDI frames.
CONTROL MESSAGESThis node type supports the generic control messages.
SHUTDOWNThis node shuts down upon receipt of a NGM_SHUTDOWN control message, or when all hooks have been disconnected.
SEE ALSOnetgraph(4), ng_atm(4), ng_eiface(4), ngctl(8) J. Heinanen, Multiprotocol Encapsulation over ATM Adaptation Layer 5, RFC 1483.
AUTHORSBenno Rice <@FreeBSD.org>
|This manual||Reference||Other manuals|
|refer to||netgraph(4freebsd) | ng_atm(4freebsd) | ng_eiface(4freebsd)|