NG_DEVICE(4FREEBSD) - Linux man page online | Special files
Device netgraph node type.
October 19, 2004
NG_DEVICE(4) BSD Kernel Interfaces Manual NG_DEVICE(4)
BSD October 19, 2004 BSD
NAMEng_device — device netgraph node type
DESCRIPTIONA device node is both a netgraph node and a system device interface. When a device node is created, a new device entry appears which is accessible via the regular file operators such as open(2), close(2), read(2), write(2), etc. The first node is created as /dev/ngd0, all subsequent nodes /dev/ngd1, /dev/ngd2, etc.
HOOKSA device node has a single hook with an arbitrary name. All data coming in over the hook will be presented to the device for read(2). All data coming in from the device entry by write(2) will be forwarded to the hook.
CONTROL MESSAGESThe device node supports one non-generic control message: NGM_DEVICE_GET_DEVNAME Returns device name corresponding to a node.
SHUTDOWNThis node shuts down upon receipt of a NGM_SHUTDOWN control message, or upon hook disconnec‐ tion. The associated device entry is removed and becomes available for use by future device nodes.
SEE ALSOnetgraph(4), ngctl(8)
HISTORYThe device node type was first implemented in FreeBSD 5.0.
AUTHORSMark Santcroos <@ripe.net> Gleb Smirnoff <@FreeBSD.org>
|This manual||Reference||Other manuals|
|refer to||close(2) | netgraph(4freebsd) | open(2) | read(2) | write(2)|