NG_FRAME_RELAY(4FREEBSD) - Linux manual page online | Special files
Frame relay netgraph node type.
January 19, 1999
NG_FRAME_RELAY(4) BSD Kernel Interfaces Manual NG_FRAME_RELAY(4)
BSD January 19, 1999 BSD
NAMEng_frame_relay — frame relay netgraph node type
DESCRIPTIONThe frame_relay node type performs encapsulation, de-encapsulation, and multiplexing of packets using the frame relay protocol. It supports up to 1024 DLCI's. The LMI protocol is handled by a separate node type (see ng_lmi(4)). The downstream hook should be connected to the synchronous line, i.e., the switch. Then hooks dlci0, dlci1, through dlci1023 are available to connect to each of the DLCI channels.
HOOKSThis node type supports the following hooks: downstream The connection to the synchronous line. dlciX Here X is a decimal number from 0 to 1023. This hook corresponds to the DLCI X frame relay virtual channel.
CONTROL MESSAGESThis node type supports only the generic control messages.
SHUTDOWNThis node shuts down upon receipt of a NGM_SHUTDOWN control message, or when all hooks have been disconnected.
SEE ALSOnetgraph(4), ng_lmi(4), ngctl(8)
HISTORYThe ng_frame_relay node type was implemented in FreeBSD 4.0.
AUTHORSJulian Elischer <@FreeBSD.org>
BUGSTechnically, frames on DLCI X should not be transmitted to the switch until the LMI protocol entity on both ends has configured DLCI X as active. The ng_frame_relay node type ignores this restriction, and will always pass data received on a DLCI hook to downstream. Instead, it should query the LMI node first.
|This manual||Reference||Other manuals|
|ng_frame_relay(4freebsd)||referred by||netgraph(4freebsd) | ng_lmi(4freebsd) | ng_rfc1490(4freebsd)|
|refer to||netgraph(4freebsd) | ng_lmi(4freebsd)|