NG_HOLE(4FREEBSD) - Linux man page online | Special files
Netgraph discard node type.
May 19, 2004
NG_HOLE(4) BSD Kernel Interfaces Manual NG_HOLE(4)
BSD May 19, 2004 BSD
NAMEng_hole — netgraph discard node type
SYNOPSIS#include <sys/types.h> #include <netgraph/ng_hole.h>
DESCRIPTIONThe hole node type silently discards all data and control messages it receives. This type is used for testing and debugging.
HOOKSA ng_hole node accepts any request to connect, regardless of the hook name, as long as the name is unique.
CONTROL MESSAGESThis node type supports the generic control messages, plus the following: NGM_HOLE_GET_STATS (getstats) This command takes an ASCII string argument, the hook name, and returns the statistics associated with the hook as a struct ng_hole_hookstat. NGM_HOLE_CLR_STATS (clrstats) This command takes an ASCII string argument, the hook name, and clears the statistics associated with the hook. NGM_HOLE_GETCLR_STATS (getclrstats) This command is identical to NGM_HOLE_GET_STATS, except that the statistics are also atomically cleared.
SHUTDOWNThis node shuts down upon receipt of a NGM_SHUTDOWN control message, or when all hooks have been disconnected.
SEE ALSOnetgraph(4), ng_echo(4), ngctl(8)
HISTORYThe ng_hole node type was implemented in FreeBSD 4.0.
AUTHORSJulian Elischer <@FreeBSD.org>
|This manual||Reference||Other manuals|
|ng_hole(4freebsd)||referred by||netgraph(4freebsd) | ng_echo(4freebsd) | ng_ether_echo(4freebsd) | ng_source(4freebsd)|
|refer to||netgraph(4freebsd) | ng_echo(4freebsd)|