NG_SPLIT(4FREEBSD) - Linux man page online | Special files
Netgraph node to separate incoming and outgoing flows.
February 19, 2001
NG_SPLIT(4) BSD Kernel Interfaces Manual NG_SPLIT(4)
BSD February 19, 2001 BSD
NAMEng_split — netgraph node to separate incoming and outgoing flows
DESCRIPTIONThe split node type is used to split a bidirectional stream of packets into two separate unidirectional streams of packets.
HOOKSThis node type supports the following three hooks: in Packets received on in are forwarded to mixed. out Packets received on out will be discarded as illegal. mixed Packets received on mixed are forwarded to out.
CONTROL MESSAGESThis node type supports only the generic control messages.
SHUTDOWNThis node shuts down upon receipt of a NGM_SHUTDOWN control message, or when all hooks have been disconnected.
SEE ALSOnetgraph(4), ngctl(8)
HISTORYThe ng_split node type was implemented in FreeBSD 3.5 but incorporated into FreeBSD in FreeBSD 5.0.
AUTHORSJulian Elischer <@FreeBSD.org> Vitaly V. Belekhov <@riss-telecom.ru>
|This manual||Reference||Other manuals|