NVD(4FREEBSD) - Linux manual page online | Special files
NVM Express disk driver.
January 28, 2016
NVD(4) BSD Kernel Interfaces Manual NVD(4)
BSD January 28, 2016 BSD
NAMEnvd — NVM Express disk driver
SYNOPSISTo compile this driver into your kernel, place the following lines in your kernel configura‐ tion file: device nvme device nvd Or, to load the driver as a module at boot, place the following lines in loader.conf(5): nvme_load="YES" nvd_load="YES"
DESCRIPTIONThe nvd driver exposes NVM Express (NVMe) namespaces as disks to the kernel disk storage API. It depends on the nvme(4) driver for notification of existing NVMe namespaces and sub‐ mission of NVM I/O commands. Device nodes from the nvd driver will have the format /dev/nvdX and are GEOM(4) disks which can be partitioned by geom(8). Note that device nodes from the nvme(4) driver are not GEOM(4) disks and cannot be partitioned.
CONFIGURATIONThe nvd driver defines a system-wide maximum delete size for NVMe devices. The default is 1GB. To select a different value, set the following tunable in loader.conf(5): hw.nvd.delete_max=<delete size in bytes>
SEE ALSOGEOM(4), nvme(4), geom(8), nvmecontrol(8), disk(9)
HISTORYThe nvd driver first appeared in FreeBSD 9.2.
AUTHORSThe nvd driver was developed by Intel and originally written by Jim Harris <@FreeBSD.org>, with contributions from Joe Golio at EMC. This man page was written by Jim Harris <@FreeBSD.org>.
|This manual||Reference||Other manuals|
|refer to||disk(9freebsd) | nvme(4freebsd)|