OCE(4FREEBSD) - Linux man page online | Special files
Device driver for Emulex OneConnect 10Gb network adapters.
February 19, 2012
OCE(4) BSD Kernel Interfaces Manual OCE(4)
BSD February 19, 2012 BSD
NAMEoce — Device driver for Emulex OneConnect 10Gb network adapters
SYNOPSISTo compile this driver into the kernel, place the following lines in your kernel configura‐ tion file: device pci device oce Alternatively, to load the driver as a module at boot time, place the following line in loader.conf(5): if_oce_load="YES"
DESCRIPTIONEmulex OneConnect adapters come in various skews and with different combinations of NIC, FCoE and iSCSI functions. The oce driver claims the NIC functions in all these adapters. The oce driver supports VLAN Hardware offload, TCP checksum offload, TCP segmentation off‐ load (TSO), Large receive offload (LRO), Bonding, Jumbo frames (from 1500 - 9000), Multiple TX queues, Receive-Side Scaling (RSS) and MSI-X interrupts.
HARDWAREThe oce driver supports the following network adapters: · Emulex BladeEngine 2 · Emulex BladeEngine 3 · Emulex Lancer
UPDATING FIRMWAREAdapter firmware updates are persistent. Firmware can be updated by following the steps below: 1. Copy the below code to a Makefile: KMOD=elxflash FIRMWS=imagename.ufi:elxflash .include <bsd.kmod.mk> 2. Replace imagename in above with UFI file name 3. Copy Makefile and UFI file to a directory 4. Execute make & copy generated elxflash.ko to /lib/modules 5. sysctl dev.oce.<if_id>.fw_upgrade=elxflash 6. Reboot the machine In case of issues with supplied UFI, flashing fails with one of the following errors. 1. "Invalid BE3 firmware image" 2. "Invalid Cookie. Firmware image corrupted ?" 3. "cmd to write to flash rom failed."
SUPPORTFor general information and support, go to the Emulex website at: http://www.Emulex.com/ or E-Mail at @emulex.com.
AUTHORSThe oce driver was written by @emulex.com.
|This manual||Reference||Other manuals|