PCF(4FREEBSD) - Linux man page online | Special files
Philips I2C bus controller.
August 6, 1998
PCF(4) BSD Kernel Interfaces Manual PCF(4)
BSD August 6, 1998 BSD
NAMEpcf — Philips I2C bus controller
SYNOPSISdevice pcf In /boot/device.hints: hint.pcf.0.at="isa" hint.pcf.0.port="0x320" hint.pcf.0.irq="5" For one or more iicbus busses: device iicbus
DESCRIPTIONThe pcf driver provides support to the Philips PCF8584 I2C controller for the iicbus(4) sys‐ tem. The PCF8584 is an integrated circuit designed in CMOS technology which serves as an inter‐ face between most standard parallel-bus microcontrollers/microprocessors and the serial I2C- bus. The PCF8584 provides both master and slave functions. Communication with I2C-bus is carried out on a byte-wise basis using interrupt or polled handshake. It controls all the I2C-bus specific sequences, protocol, arbitration and timing. The PCF8584 allows parallel- bus systems to communicate bidirectionally with the I2C-bus.
HISTORYThe pcf manual page first appeared in FreeBSD 3.0.
AUTHORSThis manual page was written by Nicolas Souchu.
|This manual||Reference||Other manuals|