PNP(4FREEBSD) - Linux man page online | Special files
Support for “Plug and Play” (PnP) ISA devices.
September 20, 2001
PNP(4) BSD/i386 Kernel Interfaces Manual PNP(4)
BSD September 20, 2001 BSD
NAMEpnp — support for “Plug and Play” (PnP) ISA devices
DESCRIPTIONThe pnp driver enumerates ISA devices which support “Plug and Play ISA Specification” in the system. It assigns ISA bus resources (interrupt line, DMA channel, I/O ports, and memory region) to each device and activates it. If it cannot assign necessary resources to a PnP ISA device without causing conflict with other devices in the system, the device will not be activated and will be unavailable to programs.
STANDARDSIntel and Microsoft, Plug and Play ISA Specification, Version 1.0a, May 5, 1994. Clarifications to the Plug and Play ISA Specification, Version 1.0a, December 10, 1994.
HISTORYThe pnp driver first appeared in FreeBSD 2.2.5. It has been substantially updated in subse‐ quent versions.
AUTHORSPnP support was originally written for FreeBSD 2.2.5 by Luigi Rizzo, based on initial work done by Sujal Patel.
CAVEATSIt is not possible to disable individual PnP ISA devices. The pnp driver will find all devices conforming the PnP ISA specification and try to activate them all. There is no way to explicitly assign particular resource to the PnP ISA device. The resource assignment is fully automatic and there is no provision for manual override.
|This manual||Reference||Other manuals|