PROCDESC(4FREEBSD) - Linux man page online | Special files
Process descriptor facility.
July 25, 2015
PROCDESC(4) BSD Kernel Interfaces Manual PROCDESC(4)
BSD July 25, 2015 BSD
NAMEprocdesc — process descriptor facility
DESCRIPTIONprocdesc is a file-descriptor-oriented interface to process signalling and control, which supplements historic UNIX fork(2), kill(2), and wait4(2) primitives with new system calls such as pdfork(2), pdkill(2), and pdwait4(2). procdesc is designed for use with capsicum(4), replacing process identifiers with capability-oriented references. However, it can also be used independently of capsicum(4), displacing PIDs, which may otherwise suffer from race conditions. Given a process descriptor, it is possible to query its conventional PID using pdgetpid(2).
SEE ALSOfork(2), kill(2), pdfork(2), pdgetpid(2), pdkill(2), pdwait4(2), wait4(2), capsicum(4)
HISTORYprocdesc first appeared in FreeBSD 9.0, and was developed at the University of Cambridge.
AUTHORSprocdesc was developed by Robert Watson <@FreeBSD.org> and Jonathan Anderson <@FreeBSD.org> at the University of Cambridge, and Ben Laurie <@FreeBSD.org> and Kris Kennaway <@FreeBSD.org> at Google, Inc.
|This manual||Reference||Other manuals|
|procdesc(4freebsd)||referred by||capsicum(4freebsd) | pdfork(2freebsd) | pdgetpid(2freebsd) | pdkill(2freebsd) | pdwait4(2freebsd)|
|refer to||capsicum(4freebsd) | fork(2) | kill(2) | pdfork(2freebsd) | pdgetpid(2freebsd) | pdkill(2freebsd) | pdwait4(2freebsd) | wait4(2)|