PSEUDOFS(9FREEBSD) - man page online | system kernel interfaces
Pseudo file system construction kit.
April 20, 2007
PSEUDOFS(9) BSD Kernel Developer's Manual PSEUDOFS(9)
NAMEpseudofs — pseudo file system construction kit
DESCRIPTIONThe pseudofs module offers an abstract API for pseudo-file systems such as procfs(5) and linprocfs(5). It takes care of all the hairy bits like interfacing with the VFS system, enforcing access control, keeping track of file numbers, and cloning files and directories that are process-specific. The consumer module, i.e., the module that implements the actual guts of the file system, needs only provide the directory structure (represented by a col‐ lection of structures declared and initialized by macros provided by pseudofs) and callbacks that report file attributes or write the actual file contents into sbufs.
SEE ALSOlinprocfs(5), linsysfs(5), procfs(5), sbuf(9), vnode(9)
HISTORYThe pseudofs module appeared in FreeBSD 5.0.
BSD April 20, 2007 BSD
AUTHORSThe pseudofs module and this manual page were written by Dag-Erling Smørgrav <@FreeBSD.org>.
|This manual||Reference||Other manuals|
|refer to||proc(5) | sbuf(9freebsd) | vnode(9freebsd)|