SCHED_4BSD(4FREEBSD) - Linux manual page online | Special files
January 21, 2008
SCHED_4BSD(4) BSD Kernel Interfaces Manual SCHED_4BSD(4)
BSD January 21, 2008 BSD
NAMEsched_4bsd — 4.4BSD scheduler
DESCRIPTIONThe sched_4bsd scheduler is the traditional system scheduler, providing both high throughput and solid interactive response in the presence of load. The following sysctls are relevant to the operation of sched_4bsd: kern.sched.name This read-only sysctl reports the name of the active scheduler. kern.sched.quantum This read-write sysctl reports or sets the length of the quantum (in micro-seconds) granted to a thread. kern.sched.ipiwakeup.enabled This read-write sysctl sets whether or not the scheduler will generate an inter-pro‐ cessor interrupt (IPI) to an idle CPU when a thread is woken up. Otherwise, idle CPUs will wait until the next clock tick before looking for new work. kern.sched.preemption This read-only sysctl reports whether or not the kernel is configured to support preemption, which reduces the latency to run lower priority threads on wakeup. Some sysctls will be available only on systems supporting SMP.
SEE ALSOsched_ule(4), sysctl(8)
HISTORYThe sched_4bsd scheduler has been present, in various forms, since the inception of BSD.
BUGSWhile a highly robust and time-tested scheduler, sched_4bsd lacks specific knowledge of how to schedule advantageously in non-symmetric processor configurations, such as hyper-thread‐ ing.
|This manual||Reference||Other manuals|
|sched_4bsd(4freebsd)||referred by||dtrace_sched(4freebsd) | sched_ule(4freebsd) | SMP(4freebsd) | smp(4freebsd)|
|refer to||sched_ule(4freebsd) | sysctl(8)|