SDHCI(4FREEBSD) - Linux man page online | Special files
PCI SD Host Controller bridge driver.
February 9, 2012
SDHCI(4) BSD Kernel Interfaces Manual SDHCI(4)
BSD February 9, 2012 BSD
NAMEsdhci — PCI SD Host Controller bridge driver
SYNOPSISTo compile this driver into the kernel, place the following lines in your kernel configura‐ tion file: device mmc device mmcsd device sdhci Alternatively, to load the driver as a module at boot time, place the following lines in loader.conf(5): mmc_load="YES" mmcsd_load="YES" sdhci_load="YES"
DESCRIPTIONThe sdhci driver supports PCI devices with class 8 and subclass 5 according to SD Host Con‐ troller Specification. Driver supports up to six high speed 4bit MMC/SD slots per con‐ troller. Driver attaches mmc bus to the respective slot on card insertion and detaches it on card removing.
HARDWAREThe sdhci driver supports different specification compatible chips. The following chips have been verified to work: · ENE CB712 · ENE CB714 · RICOH R5C822 · RICOH R5CE823 · TI PCIXX21/XX11
SEE ALSOmmc(4), mmcsd(4) SD Specifications, Part 2, SD Host Controller, Simplified Specification.
AUTHORSAlexander Motin <@FreeBSD.org>
BUGSMany of existing SD controller chips have some nonstandard requirements, proprietary regis‐ ters and hardware bugs, requiring additional handling. ENE chips are handled to work fine, while some revisions of RICOH and TI controllers still do not see cards without some addi‐ tional initialization.
|This manual||Reference||Other manuals|
|sdhci(4freebsd)||referred by||mmc(4freebsd) | mmcsd(4freebsd)|
|refer to||mmc(4freebsd) | mmcsd(4freebsd)|