SNC(4FREEBSD) - Linux man page online | Special files
National Semiconductor DP8393X SONIC Ethernet adapter driver.
September 4, 2004
SNC(4) BSD/i386 Kernel Interfaces Manual SNC(4)
BSD September 4, 2004 BSD
NAMEsnc — National Semiconductor DP8393X SONIC Ethernet adapter driver
SYNOPSISdevice isa device snc
DESCRIPTIONThe snc driver provides support for the National Semiconductor SONIC Ethernet adapters.
HARDWAREThe snc driver supports the following cards: · National Semiconductor DP83934AVQB · NEC PC-9801-83 · NEC PC-9801-84 · NEC PC-9801-103 · NEC PC-9801-104 · NEC PC-9801N-15 · NEC PC-9801N-25 · NEC PC-9801N-J02 PCMCIA · NEC PC-9801N-J02R PCMCIA The snc driver also includes support for the National Semiconductor NS46C46 as 64 * 16 bits Microwave Serial EEPROM.
IMPLEMENTATION NOTESAccessing SONIC card data structures and registers as 32 bit values makes code endianness independent. The SONIC is however always in big-endian mode so it is necessary to ensure that data structures shared between the CPU and the SONIC card are always in big-endian order. The snc driver supports the PC-98 C-Bus, and PnP buses. Support is also provided for the legacy C-Bus.
DIAGNOSTICSThe following driver specific error messages may be reported: snc%d: snc_nec16_register_irq: unsupported irq (%d) The card returned an IRQ which is not supported by the driver. snc%d: invalid packet length %d bytes An attempt to transfer a data packet failed due to an invalid packet length.
SEE ALSOnetintro(4), bus_alloc_resource_any(9)
HISTORYThe snc driver was ported from NetBSD by Motomichi Matsuzaki <@e-mail.ne.jp> and Hiroshi Yamashita <@msj.biglobe.ne.jp>. It first appeared in FreeBSD 4.2. This manual page first appeared in FreeBSD 5.3.
AUTHORSThis manual page was written by Tom Rhodes <@FreeBSD.org>.
BUGSCurrently the snc driver only works on the PC-98 architecture. It should probably work on the i386 architecture as well.
|This manual||Reference||Other manuals|
|refer to||bus_alloc_resource_any(9freebsd) | netintro(4freebsd)|