SND_VIA8233(4FREEBSD) - Linux man page online | Special files
VIA Technologies VT8233 bridge device driver.
November 29, 2006
SND_VIA8233(4) BSD Kernel Interfaces Manual SND_VIA8233(4)
BSD November 29, 2006 BSD
NAMEsnd_via8233 — VIA Technologies VT8233 bridge device driver
SYNOPSISTo compile this driver into the kernel, place the following lines in your kernel configura‐ tion file: device sound device snd_via8233 Alternatively, to load the driver as a module at boot time, place the following line in loader.conf(5): snd_via8233_load="YES"
DESCRIPTIONThe snd_via8233 bridge driver allows the generic audio driver, sound(4), to attach to the VIA VT8233 audio devices. These audio chipsets are integrated in the southbridge on many VIA based motherboards. Runtime Configuration The following sysctl(8) variables are available in addition to those available to all sound(4) devices: dev.pcm.%d.polling Experimental polling mode, where the driver operates by querying the device state on each tick using callout(9). Polling is dis‐ abled by default. Do not enable it unless you are facing weird interrupt problems or if the device cannot generate interrupts at all.
HARDWAREThe snd_via8233 driver supports the following audio chipsets: · VIA VT8233 · VIA VT8233A · VIA VT8233C · VIA VT8235 · VIA VT8237 · VIA VT8251
HISTORYThe snd_via8233 device driver first appeared in FreeBSD 4.7.
AUTHORSThis manual page was written by Joel Dahl <@FreeBSD.org>.
BUGSThe snd_via8233 driver does not support S/PDIF. There is partial support in the code, so implementing it should be fairly easy if the right hardware is available.
|This manual||Reference||Other manuals|
|snd_via8233(4freebsd)||referred by||pcm(4freebsd) | snd(4freebsd) | sound(4freebsd)|
|refer to||callout(9freebsd) | sound(4freebsd) | sysctl(8)|