UIHOLD(9FREEBSD) - Linux man page online | System kernel interfaces
Functions for managing UID information.
July 10, 2001
UIDINFO(9) BSD Kernel Developer's Manual UIDINFO(9)
BSD July 10, 2001 BSD
NAMEuidinfo, uihashinit, uifind, uihold, uifree — functions for managing UID information
SYNOPSIS#include <sys/param.h> #include <sys/proc.h> #include <sys/resourcevar.h> void uihashinit(void); struct uidinfo * uifind(uid_t uid); void uihold(struct uidinfo *uip); void uifree(struct uidinfo *uip);
DESCRIPTIONThe uidinfo family of functions is used to manage uidinfo structures. Each uidinfo struc‐ ture maintains per uid resource consumption counts, including the process count and socket buffer space usage. The uihashinit() function initializes the uidinfo hash table and its mutex. This function should only be called during system initialization. The uifind() function looks up and returns the uidinfo structure for uid. If no uidinfo structure exists for uid, a new structure will be allocated and initialized. The uidinfo hash mutex is acquired and released. The uihold() function increases the reference count on uip. uip's lock is acquired and released. The uifree() function decreases the reference count on uip, and if the count reaches 0 uip is freed. uip's lock is acquired and release and the uidinfo hash mutex may be acquired and released.
RETURN VALUESuifind() returns a pointer to an initialized uidinfo structure, and should not fail.
AUTHORSThis manual page was written by Chad David <@acns.ab.ca>.
|This manual||Reference||Other manuals|
|uihold(9freebsd)||referred by||crcopy(9freebsd) | crcopysafe(9freebsd) | crdup(9freebsd) | cred_update_thread(9freebsd) | crfree(9freebsd) | crget(9freebsd) | crhold(9freebsd) | crsetgroups(9freebsd) | crshared(9freebsd) | cru2x(9freebsd) | ucred(9freebsd)|