VCOUNT(9FREEBSD) - man page online | system kernel interfaces
Get total number of references to a device.
January 19, 2012
VCOUNT(9) BSD Kernel Developer's Manual VCOUNT(9)
NAMEvcount, count_dev — get total number of references to a device
SYNOPSIS#include <sys/param.h> #include <sys/time.h> #include <sys/conf.h> #include <sys/vnode.h> int vcount(struct vnode *vp); int count_dev(struct cdev *dev);
DESCRIPTIONvcount() is used to get the number of references to a particular device. It allows for the fact that multiple vnodes may reference the same device. count_dev() does the same thing as vcount(), but takes a struct cdev rather than a struct vnode pointer as an argument.
RETURN VALUESvcount() and count_dev() both return the number of references to the device.
SEE ALSOVFS(9), vnode(9)
BSD January 19, 2012 BSD
AUTHORSThis manual page was written by Andrew Stevenson.
|This manual||Reference||Other manuals|
|refer to||VFS(9freebsd) | vnode(9freebsd)|