VGONE(9FREEBSD) - man page online | system kernel interfaces
Prepare a vnode for reuse.
November 12, 2010
VGONE(9) BSD Kernel Developer's Manual VGONE(9)
NAMEvgone — prepare a vnode for reuse
SYNOPSIS#include <sys/param.h> #include <sys/vnode.h> void vgone(struct vnode *vp);
DESCRIPTIONThe vgone() function prepares the vnode to be destroyed. The preparation includes the cleaning of all file system specific data and the removal from its mount point vnode list. If the vnode has a v_usecount of zero, and its VI_DOOMED flag is not set, it is moved to the head of the free list as in most cases the vnode is about to be reused, or its file system is being unmounted. The vgone() function takes an exclusively locked vnode, and returns with the vnode exclu‐ sively locked.
BSD November 12, 2010 BSD
AUTHORSThis manual page was written by Chad David <@acns.ab.ca>.
|This manual||Reference||Other manuals|
|vgone(9freebsd)||referred by||insmntque(9freebsd) | insmntque1(9freebsd) | vflush(9freebsd)|