VIRTIO_BLK(4FREEBSD) - Linux man page online | Special files
VirtIO Block driver.
July 2, 2013
VIRTIO_BLK(4) BSD Kernel Interfaces Manual VIRTIO_BLK(4)
BSD July 2, 2013 BSD
NAMEvirtio_blk — VirtIO Block driver
SYNOPSISTo compile this driver into the kernel, place the following lines in your kernel configura‐ tion file: device virtio_blk Alternatively, to load the driver as a module at boot time, place the following line in loader.conf(5): virtio_blk_load="YES"
DESCRIPTIONThe virtio_blk device driver provides support for VirtIO block devices.
LOADER TUNABLESTunables can be set at the loader(8) prompt before booting the kernel or stored in loader.conf(5). hw.vtblk.no_ident hw.vtblk.X.no_ident These tunables disable retrieving the device identification string from the hypervi‐ sor either globally or per-device. The default value is 0. hw.vtblk.writecache_mode hw.vtblk.X.writecache_mode These tunables determine the write cache mode globally or per-device. The mode can changed only if the ConfigWCE feature is negotiated. Set to 0 for writethrough mode, 1 for writeback mode, and -1 to leave it as-is. The default value is to leave as-is.
SYSCTL VARIABLESThe following variables are available as sysctl(8) variables. dev.vtblk.X.writecache_mode The write cache mode of the device can be either writethrough (0) or writeback (1). If the ConfigWCE feature is negotiated, the write cache mode can be toggled between writethrough and writeback.
HISTORYThe virtio_blk driver was written by Bryan Venteicher <@FreeBSD.org>. It first appeared in FreeBSD 9.0.
|This manual||Reference||Other manuals|
|refer to||sysctl(8) | virtio(4freebsd)|