VIRTIO_SCSI(4FREEBSD) - Linux man page online | Special files
VirtIO SCSI driver.
June 24, 2012
VIRTIO_SCSI(4) BSD Kernel Interfaces Manual VIRTIO_SCSI(4)
BSD June 24, 2012 BSD
NAMEvirtio_scsi — VirtIO SCSI driver
SYNOPSISTo compile this driver into the kernel, place the following lines in your kernel configura‐ tion file: device virtio_scsi Alternatively, to load the driver as a module at boot time, place the following line in loader.conf(5): virtio_scsi_load="YES"
DESCRIPTIONThe virtio_scsi device driver provides support for VirtIO SCSI devices.
LOADER TUNABLESTunables can be set at the loader(8) prompt before booting the kernel or stored in loader.conf(5). hw.vtscsi.bus_reset_disable In the initial QEMU release with VirtIO SCSI support, in-flight operations were not aborted when stopping the device, rendering bus reset ineffective. This tunable disables attempts to issue reset bus commands. The default value is 1.
DEBUGGINGTo enable debugging prints from the virtio_scsi driver, set the hw.vtscsi.X.debug_level variable, where X is the adapter number, either in loader.conf(5) or via sysctl(8). The following bits have the described effects: 0x01 Enable informational prints. 0x02 Enable prints for driver errors. 0x04 Enable tracing prints.
HISTORYThe virtio_scsi driver was written by Bryan Venteicher <@FreeBSD.org>. It first appeared in FreeBSD 10.0.
|This manual||Reference||Other manuals|
|refer to||sysctl(8) | virtio(4freebsd)|