BUS_ADD_CHILD(9FREEBSD) - Linux man page online | System kernel interfaces
Add a device node to the tree with a given priority.
October 28, 2015
BUS_ADD_CHILD(9) BSD Kernel Developer's Manual BUS_ADD_CHILD(9)
BSD October 28, 2015 BSD
NAMEBUS_ADD_CHILD — add a device node to the tree with a given priority
SYNOPSIS#include <sys/param.h> #include <sys/bus.h> int BUS_ADD_CHILD(device_t dev, int order, const char *name, int unit);
DESCRIPTIONThe BUS_ADD_CHILD() method is used by the driver identify routine to add devices to the tree. It can also be used to add children to buses that implement this routine in other contexts, although the behavior is bus specific. Please see device_add_child(9) for more details. The interface is the same as device_add_child(9) however, the bus' BUS_ADD_CHILD() is called. Buses implementing BUS_ADD_CHILD() should insert the device into the tree using device_add_child(9) before adding things such as their own ivars and resource lists to the device. BUS_ADD_CHILD() is not called by device_add_child(9). BUS_ADD_CHILD() instead calls device_add_child(9). A panic will result when called for a bus that does not implement BUS_ADD_CHILD(). Some buses require a special bus-specific routine to be called instead of BUS_ADD_CHILD().
RETURN VALUESThe BUS_ADD_CHILD() method returns device_t added to the tree, or NULL to indicate failure.
SEE ALSOdevice(9), device_add_child(9), driver(9)
AUTHORSThis manual page was written by M. Warner Losh.
|This manual||Reference||Other manuals|
|BUS_ADD_CHILD(9freebsd)||referred by||BUS_CHILD_DELETED(9freebsd) | device_add_child(9freebsd) | device_add_child_ordered(9freebsd) | DEVICE_IDENTIFY(9freebsd)|
|refer to||device(9freebsd) | device_add_child(9freebsd) | driver(9freebsd)|