BUS_CHILD_DELETED(9FREEBSD) - Linux man page online | System kernel interfaces
Notify a bus device that a child is being deleted.
August 21, 2012
BUS_CHILD_DELETED(9) BSD Kernel Developer's Manual BUS_CHILD_DELETED(9)
BSD August 21, 2012 BSD
NAMEBUS_CHILD_DELETED — notify a bus device that a child is being deleted
SYNOPSIS#include <sys/param.h> #include <sys/bus.h> void BUS_CHILD_DELETED(device_t dev, device_t child);
DESCRIPTIONThe BUS_CHILD_DELETED() method is invoked by the new-bus framework when a device is deleted. A bus driver can provide an implementation of this method to release bus-specific resources associated with a device such as instance variables.
SEE ALSOBUS_ADD_CHILD(9), device(9)
HISTORYThe BUS_CHILD_DELETED() method first appeared in FreeBSD 10.0.
|This manual||Reference||Other manuals|
|refer to||BUS_ADD_CHILD(9freebsd) | device(9freebsd)|