BUS_NEW_PASS(9FREEBSD) - Linux man page online | System kernel interfaces
Notify a bus that the pass level has been changed.
June 8, 2009
BUS_NEW_PASS(9) BSD Kernel Developer's Manual BUS_NEW_PASS(9)
BSD June 8, 2009 BSD
NAMEBUS_NEW_PASS — notify a bus that the pass level has been changed
SYNOPSIS#include <sys/param.h> #include <sys/bus.h> void BUS_NEW_PASS(device_t dev);
DESCRIPTIONThe BUS_NEW_PASS() method is called on each bus device to rescan the device tree when the pass level has been changed. This method is responsible for invoking BUS_NEW_PASS on child bus devices to propagate the rescan to child devices. It is also responsible for reprobing any unattached child devices and allowing drivers for the current pass to identify new chil‐ dren. A default implementation is provided by bus_generic_new_pass(9).
SEE ALSObus_generic_new_pass(9), bus_set_pass(9), device(9)
|This manual||Reference||Other manuals|
|BUS_NEW_PASS(9freebsd)||referred by||bus_generic_new_pass(9freebsd) | bus_set_pass(9freebsd)|
|refer to||bus_generic_new_pass(9freebsd) | bus_set_pass(9freebsd) | device(9freebsd)|