BUS_PRINT_CHILD(9FREEBSD) - man page online | system kernel interfaces
Print information about a device.
January 6, 2005
BUS_PRINT_CHILD(9) BSD Kernel Developer's Manual BUS_PRINT_CHILD(9)
NAMEBUS_PRINT_CHILD — print information about a device
SYNOPSIS#include <sys/param.h> #include <sys/bus.h> int BUS_PRINT_CHILD(device_t dev, device_t child);
DESCRIPTIONThe BUS_PRINT_CHILD() method is called from system code which prints out a description of a device. It should describe the attachment that the child has with the parent. For instance the TurboLaser bus prints which node the device is attached to. Please see bus_generic_print_child(9) for more information regarding the proper formatting of the mes‐ sages printed by BUS_PRINT_CHILD().
RETURN VALUESThe number of characters output.
SEE ALSOdevice(9), driver(9)
BSD January 6, 2005 BSD
AUTHORSThis manual page was written by Doug Rabson.
|This manual||Reference||Other manuals|
|refer to||bus_generic_print_child(9freebsd) | device(9freebsd) | driver(9freebsd)|