ACPI_TOSHIBA(4FREEBSD) - Linux man page online | Special files
Toshiba HCI interface.
February 8, 2010
ACPI_TOSHIBA(4) BSD Kernel Interfaces Manual ACPI_TOSHIBA(4)
BSD February 8, 2010 BSD
NAMEacpi_toshiba — Toshiba HCI interface
SYNOPSISTo compile this driver into the kernel, place the following line in your kernel configura‐ tion file: device acpi_toshiba Alternatively, to load the driver as a module at boot time, place the following line in loader.conf(5): acpi_toshiba_load="YES"
DESCRIPTIONHCI is Toshiba's Hardware Control Interface which is somewhat uniform across their models. The acpi_toshiba driver allows the user to manipulate HCI-controlled hardware using a number of sysctl(8) variables.
SYSCTL VARIABLESThe following sysctls are currently implemented: hw.acpi.toshiba.force_fan Causes active cooling to be forcibly enabled (‘1’) or disabled (‘0’) regardless of the current temperature. hw.acpi.toshiba.video_output Sets the active display to use according to a bitwise OR of the following: 0 No display 1 LCD 2 CRT 4 TV-Out Only some systems (i.e., the Libretto L5) support video switching via this hardware- specific driver. Use the acpi_video(4) driver for generic video output support. hw.acpi.toshiba.lcd_brightness Makes the LCD backlight brighter or dimmer (higher values are brighter). hw.acpi.toshiba.lcd_backlight Turns the LCD backlight on and off. hw.acpi.toshiba.cpu_speed Sets the CPU speed to the specified speed. This provides functionality similar to the hw.acpi.cpu.throttle_state variable. Higher sysctl values mean lower CPU speeds. Defaults for these variables can be set in sysctl.conf(5), which is parsed at boot-time.
LOADER TUNABLESThe hw.acpi.toshiba.enable_fn_keys tunable enables or disables the function keys on the key‐ board. Function keys are enabled by default. This behaviour can be changed at the loader(8) prompt or in loader.conf(5).
SEE ALSOacpi(4), acpi_video(4), loader.conf(5), sysctl.conf(5), sysctl(8)
HISTORYThe acpi_toshiba driver first appeared in FreeBSD 5.1.
AUTHORSThe acpi_toshiba driver was written by Hiroyuki Aizu <@navi.org>. This manual page was written by Philip Paeps <@FreeBSD.org>.
|This manual||Reference||Other manuals|
|refer to||acpi(4freebsd) | acpi_video(4freebsd) | sysctl(8) | sysctl.conf(5)|