ACPI_VIDEO(4FREEBSD) - Linux man page online | Special files
ACPI Video Extensions driver.
November 8, 2004
ACPI_VIDEO(4) BSD Kernel Interfaces Manual ACPI_VIDEO(4)
BSD November 8, 2004 BSD
NAMEacpi_video — ACPI Video Extensions driver
DESCRIPTIONThis driver uses the ACPI Video Extensions to control display switching and backlight brightness. The availability of the sysctl(8) variables depends on the functions offered by the host's ACPI implementation.
SYSCTL VARIABLESThe following sysctls are currently implemented, where ⟨device⟩ is crt, lcd, or tv: hw.acpi.video.⟨device⟩.active Current state of the output device. hw.acpi.video.⟨device⟩.levels List of supported brightness levels. hw.acpi.video.⟨device⟩.brightness Current brightness level of the device. hw.acpi.video.⟨device⟩.fullpower Preset brightness level to be used in full power mode. hw.acpi.video.⟨device⟩.economy Preset brightness level to be used in economy mode. Defaults for these variables can be set in sysctl.conf(5), which is parsed at boot-time.
SEE ALSOacpi(4), loader.conf(5), sysctl.conf(5), sysctl(8)
HISTORYThe acpi_video driver first appeared in FreeBSD 5.3.
AUTHORSThe acpi_video driver was written by Taku YAMAMOTO <@cent.saitama-u.ac.jp>. This manual page was written by Mark Santcroos <@ripe.net>.
BUGSSome systems only perform output switching via SMM even though they export the proper infor‐ mation via ACPI. On such systems, the proper hotkeys or OEM driver (for example, acpi_toshiba(4)) must be used instead.
|This manual||Reference||Other manuals|
|acpi_video(4freebsd)||referred by||acpi(4freebsd) | acpi_asus(4freebsd) | acpi_asus_wmi(4freebsd) | acpi_toshiba(4freebsd) | dpms(4freebsd)|
|refer to||acpi(4freebsd) | acpi_toshiba(4freebsd) | sysctl(8) | sysctl.conf(5)|