ALTERA_ATSE(4FREEBSD) - Linux man page online | Special files
Driver for the Altera Triple-Speed Ethernet MegaCore.
May 21, 2014
ALTERA_ATSE(4) BSD Kernel Interfaces Manual ALTERA_ATSE(4)
BSD May 21, 2014 BSD
NAMEatse — driver for the Altera Triple-Speed Ethernet MegaCore
SYNOPSISdevice atse options ATSE_CFI_HACK In /boot/device.hints: hint.atse.0.at="nexus0" hint.atse.0.maddr=0x7f007000 hint.atse.0.msize=0x540 hint.atse.0.rc_irq=1 hint.atse.0.rx_maddr=0x7f007500 hint.atse.0.rx_msize=0x8 hint.atse.0.rxc_maddr=0x7f007520 hint.atse.0.rxc_msize=0x20 hint.atse.0.tx_irq=2 hint.atse.0.tx_maddr=0x7f007400 hint.atse.0.tx_msize=0x8 hint.atse.0.txc_maddr=0x7f007420 hint.atse.0.txc_msize=0x20 hint.e1000phy.0.at="miibus0" hint.e1000phy.0.phyno=0
DESCRIPTIONThe atse device driver provides support for the Altera Triple-Speed Ethernet MegaCore.
HARDWAREThe current version of the atse driver supports the Ethernet MegaCore as described in ver‐ sion 11.1 of Altera's documentation when the device is configured with internal FIFOs.
MAC SELECTIONThe default MAC address for each atse interface is derived from a value stored in cfi(4) flash. The value is managed by the atsectl(8) utility. Only a single MAC address may be stored in flash. If the address begins with the Altera prefix 00:07:ed and ends in 00 then up to 16 addresses will be derived from it by adding the unit number of the interface to the stored address. For other prefixes, the address will be assigned to atse0 and random addresses will be used for other interfaces. If the stored address is invalid, for example all zero's, multicast, or the default address shipped on all DE4 boards (00:07:ed:ff:ed:15) then a random address is generated when the device is attached.
SEE ALSOmiibus(4), netintro(4), ifconfig(8) Triple-Speed Ethernet MegaCore Function User Guide, Altera Corporation, November 2011.
HISTORYThe atse device driver first appeared in FreeBSD 10.0.
AUTHORSThe atse device driver and this manual page were developed by SRI International and the Uni‐ versity of Cambridge Computer Laboratory under DARPA/AFRL contract (FA8750-10-C-0237) (“CTSRD”), as part of the DARPA CRASH research programme. This device driver was written by Bjoern A. Zeeb.
BUGSThe atse driver only supports a single configuration of the MegaCore as installed on the Terasic Technologies Altera DE4 Development and Education Board. Only gigabit Ethernet speeds are currently supported.
|This manual||Reference||Other manuals|
|refer to||cfi(4freebsd) | ifconfig(8) | miibus(4freebsd) | netintro(4freebsd)|