BROOKTREE(4FREEBSD) - Linux man page online | Special files
Brooktree Bt848/849/878/879 and Pinnacle PCTV video capture driver.
January 18, 2006
BKTR(4) BSD Kernel Interfaces Manual BKTR(4)
BSD January 18, 2006 BSD
NAMEbktr — Brooktree Bt848/849/878/879 and Pinnacle PCTV video capture driver
SYNOPSISdevice bktr device iicbus device iicbb device smbus
DESCRIPTIONThe bktr driver provides support for PCI video capture and VBI capture on low cost, high performance boards. The driver is based on the Matrox Meteor driver and uses the same API. The bktr driver should support most video cards based on the Brooktree Bt848/849/878/879 Video Capture Chip. Also supported are most Pinnacle PCTV video cards. Furthermore, the driver supports FM Radio if the tuner supports it. The driver currently supports the following features: PCI to PCI dma transfer clipping yuv rgb16 rgb24 rgb32 On the supported cards, tuners and other components are interconnected with an I2C bus. The Brooktree848 chips act as a master device on the bus to control them. Therefore, iicbus(4), iicbb(4) and smbus(4) controller declarations are mandatory to activate bktr support. The following kernel parameters may be used to further configure the driver: options BROOKTREE_ALLOC_PAGES=xxx specifies the number of contiguous pages to allocate when successfully probed. The default number of pages allocated by the kernel is 216. This means that there are (216*4096) bytes available for use. options BROOKTREE_SYSTEM_DEFAULT=BROOKTREE_PAL options BROOKTREE_SYSTEM_DEFAULT=BROOKTREE_NTSC One of these options can be used to set the default video format for the driver. This fixed random hangs and lockups with the VideoLogic Captivator PCI card. The following sysctls may be used to further configure the driver: sysctl hw.bt848.card=nnnn This can be used to override the card make which was detected at boot time. ‘nnnn’ is set to an integer from 1 to 23 taken from the following table: MIRO 1 HAUPPAUGE 2 STB 3 INTEL 4 IMS_TURBO 5 AVER_MEDIA 6 OSPREY 7 NEC_PK 8 IO_GV 9 FLYVIDEO 10 ZOLTRIX 11 KISS 12 VIDEO_HIGHWAY_XTREME 13 ASKEY_DYNALINK_MAGIC_TVIEW 14 LEADTEK 15 TERRATVPLUS 16 IO_BCTV3 17 AOPEN_VA1000 18 PINNACLE_PCTV_RAVE 19 PIXELVIEW_PLAYTV_PAK 20 TERRATVALUE 21 PIXELVIEW_PLAYTV_PRO_REV_4C 22 Bt848_MAX 23 sysctl hw.bt848.tuner=nnnn This can be used to override the tuner make which was detected at boot time. ‘nnnn’ is set to an integer from 0 to 16 taken from the following table: NO_TUNER 0 TEMIC_NTSC 1 TEMIC_PAL 2 TEMIC_SECAM 3 PHILIPS_NTSC 4 PHILIPS_PAL 5 PHILIPS_SECAM 6 TEMIC_PALI 7 PHILIPS_PALI 8 PHILIPS_FR1236_NTSC 9 /* These have FM Radio support */ PHILIPS_FR1216_PAL 10 /* These have FM Radio support */ PHILIPS_FR1236_SECAM 11 /* These have FM Radio support */ ALPS_TSCH5 12 ALPS_TSBH1 13 MT2032 14 LG_TPI8PSB12P_PAL 15 Bt848_MAX 16
HARDWAREThe bktr driver supports video capture cards based on the Brooktree Bt848/849/878/879 chips, as well as Pinnacle PCTV cards, including: · AOpen VA1000 · AVerMedia AVerTV Studio · AVerMedia TF/FM-98 · ATI TV Wonder VE · Hauppauge WinCast/TV · Hauppauge WinTV-Go-FM · Hauppauge WinTV-pci · Hauppauge WinTV-radio · Intel Smart Video Recorder III · KWORLD PCI TV Tuner · Miro PC TV · Pinnacle PCTV Pro · Pinnacle PCTV Rave · PixelView PlayTV PAK · PixelView PlayTV Pro (rev 4C, 9D) · SIGMA TV II · STB TV PCI Television Tuner · Super TV Tuner · TerraTec TValue · V-Stream XPERT TV-PVR 878 · Video Highway XTreme · VideoLogic Captivator PCI
FILES/usr/share/examples/meteor Examples of what you can do with the (similarly designed) Meteor driver. /usr/ports/multimedia/fxtv A TV and Camera display program utilizing the bktr driver - requires that The X Window System and The Ports Collection also be installed. /usr/ports/misc/alevt A program to capture and display Teletext (VideoText) pages - requires that The X Window System and The Ports Collection also be installed. /usr/ports/audio/xmradio An FM Radio Tuner for cards which have an FM Radio tuner fitted - requires that The X Window System and The Ports Collection also be installed. It also requires Motif or the lesstif port.
HISTORYThe bktr driver first appeared in FreeBSD 2.2.
AUTHORSThis driver is based on the work of Jim Lowe <@miller.cs.uwm.edu>, Mark Tinguely <@plains.nodak.edu>, Amancio Hasty <@star-gate.com>, Roger Hardiman <@FreeBSD.org> and a bunch of other people. Support for Pinnacle PCTV Rave cards was added by Branko Lankester <@euro.net>.
|This manual||Reference||Other manuals|
|refer to||bktr(4freebsd) | iicbb(4freebsd) | iicbus(4freebsd) | meteor(4freebsd) | smbus(4freebsd)|