SMBUS(4FREEBSD) - Linux man page online | Special files
System Management Bus.
August 10, 1998
SMBUS(4) BSD Kernel Interfaces Manual SMBUS(4)
BSD August 10, 1998 BSD
NAMEsmbus — System Management Bus
SYNOPSISdevice smbus device iicsmb device bktr
DESCRIPTIONThe smbus system provides a uniform, modular and architecture-independent system for the implementation of drivers to control various SMB devices and to utilize different SMB con‐ trollers (I2C, PIIX4, Brooktree848, vm86...). System Management Bus The System Management Bus is a two-wire interface through which simple power-related chips can communicate with rest of the system. It uses I2C as its backbone (see iicbus(4)). A system using SMB passes messages to and from devices instead of tripping individual con‐ trol lines. With the SMBus, a device can provide manufacturer information, tell the system what its model/part number is, save its state for a suspend event, report different types of errors, accept control parameters, and return its status. The SMBus may share the same host device and physical bus as ACCESS bus components provided that an appropriate electrical bridge is provided between the internal SMB devices and external ACCESS bus devices.
SEE ALSObktr(4), iicbus(4), iicsmb(4), smb(4) The SMBus specification, http://www.smbus.org/specs/.
HISTORYThe smbus manual page first appeared in FreeBSD 3.0.
AUTHORSThis manual page was written by Nicolas Souchu.
|This manual||Reference||Other manuals|
|smbus(4freebsd)||referred by||alpm(4freebsd) | amdpm(4freebsd) | amdsmb(4freebsd) | bktr(4freebsd) | brooktree(4freebsd) | ichsmb(4freebsd) | iicsmb(4freebsd) | intpm(4freebsd) | ismt(4freebsd) | jedec_ts(4freebsd) | nfsmb(4freebsd) | smb(4freebsd) | viapm(4freebsd)|
|refer to||bktr(4freebsd) | iicbus(4freebsd) | iicsmb(4freebsd) | smb(4freebsd)|