CFISCSI(4FREEBSD) - Linux man page online | Special files
CAM Target Layer iSCSI target frontend.
May 28, 2017
CFISCSI(4) BSD Kernel Interfaces Manual CFISCSI(4)
BSD May 28, 2017 BSD
NAMEcfiscsi — CAM Target Layer iSCSI target frontend
SYNOPSISTo compile this driver into the kernel, place the following lines in your kernel configura‐ tion file: device cfiscsi device ctl device iscsi Alternatively, to load the driver as a module at boot time, place the following line in loader.conf(5): cfiscsi_load="YES"
DESCRIPTIONThe cfiscsi subsystem provides the kernel component of an iSCSI target. The target is the iSCSI server, providing LUNs backed by local files and volumes to remote initiators. The userspace component is provided by ctld(8). cfiscsi is implemented as a ctl(4) frontend and uses infrastructure provided by iscsi(4).
SYSCTL VARIABLESThe following variables are available as both sysctl(8) variables and loader(8) tunables: kern.cam.ctl.iscsi.debug Verbosity level for log messages from the kernel part of iSCSI target. Set to 0 to disable logging or 1 to warn about potential problems. Larger values enable debug‐ ging output. Defaults to 1. kern.cam.ctl.iscsi.maxtags The number of outstanding commands to advertise to each iSCSI initiator. Current implementation is not very accurate, so do not set this below 2. Defaults to 256. kern.cam.ctl.iscsi.ping_timeout The number of seconds to wait for the iSCSI initiator to respond to a NOP-In PDU. In the event that there is no response within that time the session gets forcibly terminated. Set to 0 to disable sending NOP-In PDUs. Defaults to 5.
SEE ALSOctl(4), iscsi(4), ctl.conf(5), ctld(8)
HISTORYThe cfiscsi subsystem first appeared in FreeBSD 10.0 as part of the ctl(4) driver. It was split off of ctl(4) in FreeBSD 12.0.
AUTHORSThe cfiscsi subsystem was developed by Edward Tomasz Napierala <@FreeBSD.org> under sponsorship from the FreeBSD Foundation. This manual page was written by Ngie Cooper <@FreeBSD.org>.
|This manual||Reference||Other manuals|
|refer to||ctl(4freebsd) | iscsi(4freebsd) | sysctl(8)|