ISCSI(4FREEBSD) - Linux manual page online | Special files
May 28, 2017
ISCSI(4) BSD Kernel Interfaces Manual ISCSI(4)
BSD May 28, 2017 BSD
NAMEiscsi — iSCSI initiator
SYNOPSISTo compile this driver into the kernel, place the following line in the kernel configuration file: device iscsi Alternatively, to load the driver as a module at boot time, place the following line in loader.conf(5): iscsi_load="YES"
DESCRIPTIONThe iscsi subsystem provides the kernel component of an iSCSI initiator, responsible for implementing the Full Feature Phase of the iSCSI protocol. The initiator is the iSCSI client, which connects to an iSCSI target, providing local access to a remote block device. The userland component is provided by iscsid(8) and both the kernel and userland are config‐ ured using iscsictl(8).
SYSCTL VARIABLESThe following variables are available as both sysctl(8) variables and loader(8) tunables: kern.iscsi.debug Verbosity level for log messages from the iscsi driver. Set to 0 to disable logging or 1 to warn about potential problems. Larger values enable debugging output. Defaults to 1. kern.iscsi.ping_timeout The number of seconds to wait for the target to respond to a NOP-Out PDU. In the event that there is no response within that time the session gets forcibly restarted. Set to 0 to disable sending NOP-Out PDUs. Defaults to 5. kern.iscsi.iscsid_timeout The number of seconds to wait for iscsid(8) to establish a session. After that time iscsi will abort and retry. Defaults to 60. kern.iscsi.login_timeout The number of seconds to wait for a login attempt to succeed. After that time iscsi will abort and retry. Defaults to 60. kern.iscsi.maxtags The maximum number of outstanding IO requests. Defaults to 255. kern.iscsi.fail_on_disconnection Controls the behavior after an iSCSI connection has been dropped due to network problems. When set to 1, a dropped connection causes the iSCSI device nodes to be destroyed. After reconnecting, they will be created again. By default, the device nodes are left intact. While the connection is down all input/output operations are suspended, to be retried after the connection is reestablished.
SEE ALSOiser(4), iscsi.conf(5), iscsictl(8), iscsid(8)
HISTORYThe iscsi subsystem first appeared in FreeBSD 10.0.
AUTHORSThe iscsi subsystem was developed by Edward Tomasz Napierala <@FreeBSD.org> under spon‐ sorship from the FreeBSD Foundation.
|This manual||Reference||Other manuals|
|iscsi(4freebsd)||referred by||cfiscsi(4freebsd) | iscsi_initiator(4freebsd) | iser(4freebsd)|
|refer to||iscsid(8) | iser(4freebsd) | sysctl(8)|