CUE(4FREEBSD) - Linux man page online | Special files
CATC USB-EL1210A USB Ethernet driver.
November 24, 2015
CUE(4) BSD Kernel Interfaces Manual CUE(4)
BSD November 24, 2015 BSD
NAMEcue — CATC USB-EL1210A USB Ethernet driver
SYNOPSISTo compile this driver into the kernel, place the following lines in your kernel configura‐ tion file: device uhci device ohci device usb device miibus device uether device cue Alternatively, to load the driver as a module at boot time, place the following line in loader.conf(5): if_cue_load="YES"
DESCRIPTIONThe cue driver provides support for USB Ethernet adapters based on the Computer Access Tech‐ nology Corporation's USB-EL1210A chipset. The USB-EL1210A supports a 512-bit multicast hash filter, single perfect filter entry for the station address and promiscuous mode. Packets are received and transmitted over sepa‐ rate USB bulk transfer endpoints. The CATC chipset supports only 10Mbps half-duplex mode, hence there are no ifmedia(4) modes to select. For more information on configuring this device, see ifconfig(8).
HARDWAREThe cue driver supports CATC USB-EL1210A based USB Ethernet adapters including: · Belkin F5U011/F5U111 · CATC Netmate · CATC Netmate II · SmartBridges SmartLink
DIAGNOSTICScue%d: watchdog timeout A packet was queued for transmission and a transmit command was issued, however the device failed to acknowledge the transmission before a timeout expired. cue%d: no memory for rx list The driver failed to allocate an mbuf for the receiver ring.
SEE ALSOarp(4), netintro(4), ng_ether(4), ifconfig(8)
HISTORYThe cue device driver first appeared in FreeBSD 4.0.
AUTHORSThe cue driver was written by Bill Paul <@ee.columbia.edu>.
|This manual||Reference||Other manuals|
|cue(4freebsd)||referred by||if_cue(4freebsd) | usb(4freebsd)|
|refer to||arp(4freebsd) | ifconfig(8) | netintro(4freebsd) | ng_ether(4freebsd)|