CXGB(4FREEBSD) - Linux man page online | Special files
Chelsio T3 10 Gigabit Ethernet adapter driver.
March 14, 2007
CXGB(4) BSD Kernel Interfaces Manual CXGB(4)
BSD March 14, 2007 BSD
NAMEcxgb — Chelsio T3 10 Gigabit Ethernet adapter driver
SYNOPSISTo compile this driver into the kernel, place the following lines in your kernel configura‐ tion file: device firmware device cxgb To load the driver as a module at boot time, place the following line in loader.conf(5): if_cxgb_load="YES"
DESCRIPTIONThe cxgb driver supports Transmit/Receive checksum offload, Jumbo Frames, TCP segmentation offload (TSO), Large Receive Offload (LRO), VLAN hardware insertion / extraction, and VLAN checksum offload. For further hardware information, see http://www.chelsio.com/. For questions related to hardware requirements, refer to the documentation supplied with your Chelsio T3 adapter. All hardware requirements listed apply to use with FreeBSD. Support for Jumbo Frames is provided via the interface MTU setting. Selecting an MTU larger than 1500 bytes with the ifconfig(8) utility configures the adapter to receive and transmit Jumbo Frames. The maximum MTU size for Jumbo Frames is 9000. For more information on configuring this device, see ifconfig(8).
HARDWAREThe cxgb driver supports 10 Gigabit and 1 Gigabit Ethernet adapters based on the T3 and T3B chipset: · Chelsio 10GBase-CX4 · Chelsio 10GBase-LR · Chelsio 10GBase-SR
LOADER TUNABLESTunables can be set at the loader(8) prompt before booting the kernel or stored in loader.conf(5).
DIAGNOSTICScxgb%d: Unable to allocate bus resource: memory A fatal initialization error has occurred. cxgb%d: Unable to allocate bus resource: interrupt A fatal initialization error has occurred. cxgb%d: Could not find firmware image %s The appropriate firmware kld module was not installed. This is a fatal initialization error.
SUPPORTFor general information and support, go to the Chelsio support website at: http://www.chelsio.com/. If an issue is identified with the released source code on the supported kernel with a sup‐ ported adapter, email the specific information related to the issue to ⟨@chelsio.com⟩.
SEE ALSOaltq(4), arp(4), netintro(4), ng_ether(4), ifconfig(8)
HISTORYThe cxgb device driver first appeared in FreeBSD 6.3 and FreeBSD 7.0.
AUTHORSThe cxgb driver was written by Kip Macy <@FreeBSD.org> with substantial support from Scott Long <@FreeBSD.org>.
|This manual||Reference||Other manuals|
|cxgb(4freebsd)||referred by||cc(4freebsd) | cxgbe(4freebsd) | cxl(4freebsd) | if_cc(4freebsd) | if_cxgb(4freebsd) | if_cxgbe(4freebsd) | if_cxl(4freebsd) | if_vcc(4freebsd) | if_vcxgbe(4freebsd) | if_vcxl(4freebsd) | if_vlan(4freebsd) | vcc(4freebsd) | vcxgbe(4freebsd) | vcxl(4freebsd) | vlan(4freebsd)|
|refer to||arp(4freebsd) | ifconfig(8) | netintro(4freebsd) | ng_ether(4freebsd)|