DEVCLASS_GET_DRIVERS(9FREEBSD) - man page online | system kernel interfaces
Get a list of drivers in a devclass.
May 19, 2005
DEVCLASS_GET_DRIVERS(9) BSD Kernel Developer's Manual DEVCLASS_GET_DRIVERS(9)
NAMEdevclass_get_drivers — get a list of drivers in a devclass
SYNOPSIS#include <sys/param.h> #include <sys/bus.h> int devclass_get_drivers(devclass_t dc, driver_t ***listp, int *countp);
DESCRIPTIONRetrieve a list of pointers to all driver instances currently in the devclass and return the list in *listp and the number of drivers in the list in *countp. The memory allocated for the list should be freed using free(*listp, M_TEMP), even if *countp is 0.
RETURN VALUESZero is returned on success, otherwise an appropriate error is returned.
SEE ALSOdevclass(9), device(9)
BSD May 19, 2005 BSD
AUTHORSThis manual page was written by Nate Lawson.
|This manual||Reference||Other manuals|
|refer to||devclass(9freebsd) | device(9freebsd)|