DEVCLASS(9FREEBSD) - man page online | system kernel interfaces
Object representing a class of devices.
June 16, 1998
DEVCLASS(9) BSD Kernel Developer's Manual DEVCLASS(9)
NAMEdevclass — object representing a class of devices
SYNOPSIStypedef struct devclass *devclass_t;
DESCRIPTIONThe devclass object has two main functions in the system. The first is to manage the allo‐ cation of unit numbers for device instances and the second is to hold the list of device drivers for a particular bus type. Each devclass has a name and there cannot be two dev‐ classes with the same name. This ensures that unique unit numbers are allocated to device instances. Beware that this means devclass must be the same for different bus attachments of the same device driver.
SEE ALSOdevclass_add_driver(9), devclass_delete_driver(9), devclass_find(9), devclass_find_driver(9), devclass_get_device(9), devclass_get_devices(9), devclass_get_maxunit(9), devclass_get_name(9), devclass_get_softc(9), device(9), driver(9)
BSD June 16, 1998 BSD
AUTHORSThis manual page was written by Doug Rabson.