DHEX_SEARCHLOG(5) - Linux man page online | File formats
Search log file for dhex.
May 12, 2012
DHEX_SEARCHLOG(5) BSD File Formats Manual DHEX_SEARCHLOG(5)
BSD May 12, 2012 BSD
NAMEdhex_searchlog — search log file for dhex
DESCRIPTIONSearchlogs for dhex(1) are stored in searchlog files. This manpage describes the format of those files. EXAMPLE A typical searchlog file looks like this: ‘#DHEX SEARCHLOG’ ‘#VERSION 0’ ‘#Search was for d0 0f af fe’ ‘#lines are all in hex’ ‘0000000000002385’ ‘0000000000002e21’ ‘0000000000006acb’ ‘0000000000006b8b’ ‘000000000000cd27’
OPTIONSIn the example above, the file has two sections: A comment section, and an offset section. Comments Comments are indicated with a '#' character. Everything afterwards in a line is being ignored when parsing the file Offset section Offsets are 64 bit addresses presented as hexadecimal values. It is the offset where the searchstring occurred as result when the searchlog was written. And it is also where the next search is being conducted when reading the searchlog.
BUGSReport bugs to <@dettus.net>. Make sure to include DHEX somewhere in the subject.
AUTHORWritten by Thomas Dettbarn
SEE ALSOdhex(1), dhexrc(5), dhex_markers(5).
|This manual||Reference||Other manuals|
|dhex_searchlog(5)||referred by||dhex(1) | dhex_markers(5) | dhexrc(5)|
|refer to||dhex(1) | dhex_markers(5) | dhexrc(5)|