DISC(4FREEBSD) - Linux man page online | Special files
Software discard network interface.
May 25, 2002
DISC(4) BSD Kernel Interfaces Manual DISC(4)
BSD May 25, 2002 BSD
NAMEdisc — software discard network interface
DESCRIPTIONThe disc interface is a software discard mechanism which may be used for performance analy‐ sis and/or software testing. As with other network interfaces, the discard interface must have network addresses assigned for each address family with which it is to be used. These addresses may be set or changed with the SIOCSIFADDR ioctl(2). Each disc interface is created at runtime using interface cloning. This is most easily done with the ifconfig(8) create command or using the cloned_interfaces variable in rc.conf(5).
SEE ALSOinet(4), intro(4)
HISTORYThe disc device appears to have been derived from the lo(4) device around the time of 4.4BSD. This manpage was adapted from lo(4) and first appeared in FreeBSD 5.0.
|This manual||Reference||Other manuals|
|disc(4freebsd)||referred by||edsc(4freebsd) | if_disc(4freebsd) | if_edsc(4freebsd)|
|refer to||ifconfig(8) | inet(4freebsd) | intro(4) | ioctl(2) | lo(4freebsd)|