EHCI(4FREEBSD) - Linux man page online | Special files
USB Enhanced Host Controller driver.
March 4, 2012
EHCI(4) BSD Kernel Interfaces Manual EHCI(4)
BSD March 4, 2012 BSD
NAMEehci — USB Enhanced Host Controller driver
DESCRIPTIONThe ehci driver provides support for the USB Enhanced Host Controller Interface, which is used by USB 2.0 controllers. EHCI controllers are peculiar in that they can only handle the USB 2.0 protocol. This means that they normally have one or more companion controllers (i.e., ohci(4) or uhci(4)) han‐ dling USB 1.x devices. Consequently each USB connector is electrically connected to two USB controllers. The handling of this is totally automatic, but can be noticed since USB 1.x and USB 2.0 devices plugged in to the same connector appear to connect to different USB busses.
SEE ALSOohci(4), uhci(4), usb(4), xhci(4)
HISTORYThe ehci device driver first appeared in FreeBSD 5.1.
LOADER TUNABLESWhen the kernel has been compiled with options USB_DEBUG, some tunables become available that affect the behavior of ehci. These tunables can be set at the loader(8) prompt before booting the kernel or stored in loader.conf(5). hw.usb.ehci.lostintrbug This tunable enables the lost interrupt quirk. The default value is 0 (off). hw.usb.ehci.iaadbug This tunable enables the EHCI doorbell quirk. The default value is 0 (off). hw.usb.ehci.no_hs This tunable disables USB devices to attach like HIGH-speed ones and will force all attached devices to attach to the FULL- or LOW-speed companion controller. The default value is 0 (off).
|This manual||Reference||Other manuals|
|ehci(4freebsd)||referred by||ohci(4freebsd) | uhci(4freebsd) | umass(4freebsd) | usb(4freebsd) | xhci(4freebsd)|
|refer to||ohci(4freebsd) | uhci(4freebsd) | usb(4freebsd) | xhci(4freebsd)|