EPAIR(4FREEBSD) - man page online | special files
A pair of virtual back-to-back connected Ethernet interfaces.
July 26, 2009
EPAIR(4) BSD Kernel Interfaces Manual EPAIR(4)
NAMEepair — A pair of virtual back-to-back connected Ethernet interfaces
SYNOPSISTo compile this driver into the kernel, place the following line in your kernel configura‐ tion file: device epair Alternatively, to load the driver as a module at boot time, place the following line in loader.conf(5): if_epair_load="YES"
DESCRIPTIONThe epair is a pair of Ethernet-like software interfaces, which are connected back-to-back with a virtual cross-over cable. Each epair interface pair is created at runtime using interface cloning. This is most eas‐ ily done with the ifconfig(8) create command or using the cloned_interfaces variable in rc.conf(5). While for cloning you only give either epair or epair<n> the epair pair will be named like epair<n>[ab]. This means the names of the first epair interfaces will be epair0a and epair0b. Like any other Ethernet interface, an epair needs to have a network address. Each epair will be assigned a locally administered address by default, that is only guaranteed to be unique within one network stack. To change the default addresses one may use the SIOCSI‐ FADDR ioctl(2) or ifconfig(8) utility. The basic intend is to provide connectivity between two virtual network stack instances. When connected to a if_bridge(4) one end of the interface pair can also be part of another (virtual) LAN. As with any other Ethernet interface one can configure vlan(4) support on top of it.
SEE ALSOioctl(2), altq(4), bpf(4), if_bridge(4), vlan(4), loader.conf(5), rc.conf(5), ifconfig(8)
HISTORYThe epair interface first appeared in FreeBSD 8.0.
BSD July 26, 2009 BSD
AUTHORSThe epair interface was written by Bjoern A. Zeeb, CK Software GmbH, under sponsorship from the FreeBSD Foundation.
|This manual||Reference||Other manuals|
|epair(4freebsd)||referred by||ALTQ(4freebsd) | altq(4freebsd) | if_epair(4freebsd) | netisr(9freebsd)|
|refer to||bpf(4freebsd) | if_bridge(4freebsd) | ifconfig(8) | ioctl(2) | vlan(4freebsd)|