GEM(4FREEBSD) - man page online | special files
ERI/GEM/GMAC Ethernet device driver.
December 25, 2009
GEM(4) BSD Kernel Interfaces Manual GEM(4)
NAMEgem — ERI/GEM/GMAC Ethernet device driver
SYNOPSISTo compile this driver into the kernel, place the following lines in your kernel configura‐ tion file: device miibus device gem Alternatively, to load the driver as a module at boot time, place the following line in loader.conf(5): if_gem_load="YES"
DESCRIPTIONThe gem driver provides support for the GMAC Ethernet hardware found mostly in the last Apple PowerBooks G3s and most G4-based Apple hardware, as well as Sun UltraSPARC machines. All controllers supported by the gem driver have TCP checksum offload capability for both receive and transmit, support for the reception and transmission of extended frames for vlan(4) and a 512-bit multicast hash filter.
HARDWAREChips supported by the gem driver include: · Apple GMAC · Sun ERI 10/100 Mbps Ethernet · Sun GEM Gigabit Ethernet The following add-on cards are known to work with the gem driver at this time: · Sun Gigabit Ethernet PCI 2.0/3.0 (GBE/P) (part no. 501-4373) · Sun Gigabit Ethernet SBus 2.0/3.0 (GBE/S) (part no. 501-4375)
NOTESOn sparc64 the gem driver respects the local-mac-address? system configuration variable which can be set in the Open Firmware boot monitor using the setenv command or by eeprom(8). If set to “false” (the default), the gem driver will use the system's default MAC address for all of its devices. If set to “true”, the unique MAC address of each interface is used if present rather than the system's default MAC address. Supported interfaces having their own MAC address include the on-board Sun ERI 10/100 Mbps on boards equipped with more than one Ethernet interface and the Sun Gigabit Ethernet 2.0/3.0 GBE add-on cards.
SEE ALSOaltq(4), miibus(4), netintro(4), vlan(4), eeprom(8), ifconfig(8)
HISTORYThe gem device driver appeared in NetBSD 1.6. The first FreeBSD version to include it was FreeBSD 5.0.
BSD December 25, 2009 BSD
AUTHORSThe gem driver was written for NetBSD by Eduardo Horvath ⟨@NetBSD.org⟩. It was ported to FreeBSD by Thomas Moestl ⟨@FreeBSD.org⟩ and later on improved by Marius Strobl ⟨@FreeBSD.org⟩. The man page was written by Thomas Klausner ⟨@NetBSD.org⟩.
|This manual||Reference||Other manuals|
|gem(4freebsd)||referred by||ALTQ(4freebsd) | altq(4freebsd) | cas(4freebsd) | if_cas(4freebsd) | if_gem(4freebsd) | if_vlan(4freebsd) | miibus(4freebsd) | vlan(4freebsd)|
|refer to||ifconfig(8) | miibus(4freebsd) | netintro(4freebsd) | vlan(4freebsd)|